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Related Documentation
Related Documentation

Document set All documents relating to the installation of PL7 software can be found on the docu-
mentation CD-ROM supplied with the software.
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About the book
At a Glance

Document Scope The aim of this brief presentation of PL7 is to provide a concise overview of the soft-
ware.

Validity Note This document takes into account the changes implemented in PL7 V4. 

Related 
Documents

User Comments We welcome your comments about this document. You can reach us by e-mail at 
TECHCOMM@modicon.com
  09/2000 7
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1
 General 
Introduction

Aim of this 
Chapter

This chapter introduces the PL7 software user interface. 

What’s in this 
Chapter?

This Chapter contains the following Maps:

Topic Page

General characteristics of the user interface 10

The PL7 toolbar 12

The PL7 status bar 13

PL7 on-line Help 14

Help Topics Browser 15

PL7 contextual Help 17

The application browser 18

Structural representation 20

Functional representation 21
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 General
General characteristics of the user interface

At a Glance The packages use all the standard Windows functions: 
l mouse or keyboard,
l drop-down menus, 
l browsers,
l palettes and toolbars with icons, 
l several tools for the same function,
l on-line Help and information balloons.

Illustration The PL7 screen shown below provides an example of the numerous tools available: 

ONLINE U:SYS GR7 NOK OVRReady

STOPRUN
??? ???

STOPRUN
File Edit ?

PL7 PRO: Win01

1 8 2 5 3

Utilities View Tools PLC Debug Options Window

Application Browser

Structure view

Sr

Sections

Configuration

System 

Events
DFB Types

Variables

Animation tables
Doc. file

Runtime screens

Memory 

Title page

Program
MAST Task

Grafcet

Chart
Prl

Post

Predefined 

General 

I/O
DFB 

Constants
Grafcet objects

Software configuration
Hardware configuration

Configure Grafcet Objects

Stati

%S

SFB

%S

SFB

DFBDFB

%X%X
%K%K

%M%M

I/OI/O
Predefined 
I/O

G7G7

2

M1

3

0

 GRAFCET:  MAST  -  Grafcet - Chart

F11F8 F9F7F6F5F4F3F2 F10 F12

Variables

Parameters MEMORY EBOOL Entry field
Address Type Symbol Comment
%M0
%M1
%M2
%M3
%M4
%M5
%M6
%M7
%M8
%M9

EBO
EBO
EBO
EBO
EBO
EBO
EBO
EBO
EBO
EBO

Configuration
TSX 57402  V3.3 ... XMWI

 XTI.

0 2 3 4

0

P
S
Y

2
6
0
0

T
S
X

5
7
4
0
2

o
o

c
o
m
m
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 General
Elements and 
functions

This table describes the different elements that make up the PL7 screen: 

Number Element Function

1 Menu bar Allows access to all the software functions,

2 Toolbar Allows quick access by mouse to all basic functions,

3 Help Provides information about the software,

4 Browsers Allows direct access to different editors

5 Editors Allows creation, debugging and operation of applications,

6 Graphics palette Allows direct access to current editor tools,

7 Status bar Shows a range of information associated with the software.
  09/2000 11



 General
The PL7 toolbar

Presentation The software’s basic functions can be accessed quickly via the toolbar, using the 
mouse. 
Access to the different functions is dynamic and varies according to the context.

Illustration The PL7 toolbar is displayed as follows: 

Elements and 
functions

This table gives the function of each element in the toolbar:

STOPRUN ??? ???STOPRUN

Element Function Element Function

  New application   Local mode

  Open an application   Online mode

  Save the application   PLC changes to RUN

  Print all or part of the application   PLC changes to STOP

  Undo last modifications   Start / Stop the animation

  Confirm modifications   Organize windows so that they 
overlap

  Go to   Tile windows horizontally

  Application browser   Tile windows vertically

  Cross references   Help

  Function library   What’s this?

  PLC <-> terminal transfer

1RWH��All these functions can also be accessed via the menu.

RUN

STOP

???
???
12   09/2000



 General
The PL7 status bar

At a Glance The status bar, situated at the bottom of the screen, shows a range of information 
associated with operational aspects of the software. 

Illustration The PL7 status bar appears thus:   

Elements and 
functions

This table describes the different zones that make up the status bar: 

1 2 3 4 5 6 7 8

ONLINE STOP U:SYS GR7 OK MODIF OVR CAPSReady

Number Zone Function

1 Information supplies information concerning menu commands, toolbar 
icons and the different editors when these are selected.

2 Operating mode indicates the current operating mode (offline, online).

3 PLC state indicates the PLC state (Run, Stop, faulty, etc.). 

4 Network address gives the network address of the PLC.

5 Grafcet mode indicates whether Grafcet mode is used in the application.

6 Modification in 
progress

indicates that the current application has not been saved or is 
different from the back-up.

7 Animation indica-
tor

indicates that the PLC is in online mode.

8 Keyboard func-
tions

indicates the status of the Insert and All Caps keyboard func-
tions.
  09/2000 13



 General
PL7 on-line Help

At a Glance The PL7 on-line Help describes the implementation of different editors within the 
software. It also provides a wealth of information about: 
l users (access rights),
l general information about PL7 (application structure, adressing bit and word ob-

jects, memory management, etc.)
l PL7 language instructions (functions, syntax, operands),
l using PL7 (programming, debug, diagnostics),
l TSX Micro and Premium tasks (Regulation, Counting, Weighing, etc.).

Access mode 
using PL7

Two access modes are proposed:
l from the (Help topics) (See Help Topics Browser, p. 15) browser,
l directly from a PL7 screen  (Contextual Help)  (See PL7 contextual Help, p. 17).
14   09/2000



 General
Help Topics Browser

At a Glance The Help Topics browser provides for three types of search:
l from the Contents, which displays a view of the all the different chapters of the 

Help system,
l using the Index, which displays an alphabetical list of key words,
l using the Find mode, which displays all the words used in the on-line Help in al-

phabetical order. 

Illustration of the 
browser

The following illustration shows the browser open at Contents  

Accessing the 
browser

Contents tab

?

Help topics: PL7 Help ?

Close CancelPrint…

?
?
?
?
?
?
?
?
?
?
?
?

Click on a topic, then on Display Or click on another tab, e.g. Index

Contents

Application management

Index Find

Application browser
Functional modules
Application configuration
Editing variables
Programming in Ladder Language (LD)
Programming in Instruction List Language (IL)
Programming in Structured Text Language (ST)
Programming in Grafcet Language (GR7)
DFB function blocks
Debugging
Diagnostics
Documentation

Using the software

Step Action

1 Select the Index command from the ? menu or click on the icon .

2 Select then open the required directory.

???
  09/2000 15



 General
Index tab

Find tab 

Step Action

1 Select the Find ... command from the ? menu or click on the  icon then select 

the Index tab.

2 Enter the key word.

3 Select then open the required topic.

Step Action

1 Click on the  icon then select the Find tab.

2 Enter the word to be found.

3 Select then open the required topic.

???

???
16   09/2000



 General
PL7 contextual Help

At a Glance Contextual Help is used to directly access information from the selected element. 

Accessing the 
Contextual Help

Two exclusive modes of access are used to access Contextual Help.
Standard screens

Modal dialog boxes

Step Action

1 Select the What’s this? command from the ? menu or click on the  icon, 

2 Select the element for which you require technical information (menu, screen, tool-
bar, etc.).

Step Action

1 Click on the  icon of the current element.

???

???
  09/2000 17



 General
The application browser

At a Glance The application browser displays the contents of a PL7 application in tree diagram 
form.
Two types of representation are offered:
l structural: standard view corresponding to the PLC’s processing order,
l functional: view of the application in functional modules corresponding to the 

functions of the automatic operation.

Illustration The following screens show the two modes of representation.  

Accessing the 
browser

The following table shows the different ways of accessing the application browser.

Application Browser

Structure View

STATION
Configuration

Software configuration
Program

MAST Task
Events

DFB Types
Variables
Animation tables

Hardware configuration
Prog1

Animation tables
Program

STATION

Function View

Runtime Screens

Doc. file
Runtime Screens

From: Action

the contents Select the Tools → Application Browser command.

the tool bar See The PL7 toolbar, p. 12

1RWH��By default, the application browser opens a partial display of the directory 
tree.
l + in front of a directory indicates that it can be opened,
l - in front of a directory indicates it can be closed.
To open or close a directory, click on + or -, or use the left or right arrows on the 
keyboard. 
18   09/2000



 General
Which software 
for which mode

The following table shows the types of representation available for each software 
package:

Accessing 
different views

Click on the following icons to access the required display mode:

PL7 Micro PL7 Junior PL7 Pro

Structure view yes yes yes

Function view no no yes

Icon Action

  displays structure view

  displays function view

  juxtaposes structure view and function view

  superimposes structure view and function view
  09/2000 19



 General
Structural representation

At a Glance Structural representation shows the contents of an application as a directory tree. 
It is used to move around inside an application and provides direct access:
l to the hardware, software and Grafcet configuration,
l to the programs,
l to the DFBs contained within the application,
l to the data,
l to the animation tables,
l to parts of the file (general information, title page),
l to the runtime screens.

Illustration The following screen shows the tree structure of an application. 

Configuration editor

Program editor

DFB editor

Variables editor

Animation table editor

Documentation editor

Runtime screens editor

IL Sr0
Sr1

Sr

Sections

Configuration

System Objects

Events
DFB types

Variables

Animation tables

Runtime screens

Memory Objects

Program
MAST Task

normal_cycle

Chart
Prl

Post

Test

Predefined FBs

General information

I/O
DFB Instances

Constants
Grafcet objects

Software configuration
Hardware configuration

Configure Grafcet Objects

Station

%S

SFB

%S

SFB

DFBDFB

%X%X

%K%K

%M%M

I/OI/O

Predefined FBs
I/O

IL

G7G7

Application Browser

E4 transfer

Doc. file
Title page

A1 transfer
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 General
Functional representation

At a Glance The functional representation shows the application broken down into functional 
modules corresponding to the different functions of the application’s automatic pro-
cesses. 
A functional module is a grouping of program elements (sections, macro-steps, an-
imation tables, runtime screens, etc.).

Illustration The following screen shows an application broken down into function modules. 

1RWH��This function is available with PL7 Pro software. 

Functional module

Functional module

Functional sub-module

Application Browser

Prod1

Start_cycle
Animation tables

Table_1

E4 transfer
A1 transfer

Function View

Program

STATION

Prod2
Program
Animation table

Runtime Screens

Program
Animation tables

Mdm1

Runtime Screens

Runtime screens
  09/2000 21
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  09/2000
2
Introduction to PL7 editors
At a Glance

Overview This chapter introduces the different editors offered by PL7.

What’s in this 
Chapter?

This Chapter contains the following Maps:

1RWH��For further information (functions, access, etc.), refer to either of the follow-
ing: 
l PL7 on-line Help,
l The various manuals available on CD-ROM.

Topic Page

The configuration editor 24

Program editors: General 26

Program editor: Ladder Language (LD) 28

Program editor: Instruction List (IL) Language 30

Program editor: Structured Text language (ST) 32

Program editor: Grafcet language 33

DFB type editors 35

The variables editor 36

Animation tables editor 38

Documentation editor 40

Runtime screens editor 41
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Introduction to PL7 editors
The configuration editor

At a Glance The PL7 configuration editor maintains the following functions for each application:
l hardware configuration
l software configuration,
l Grafcet configuration, wherever programming is in Grafcet.
When connected, the configuration editor also maintains the debugging, adjustment 
and diagnostic functions.

Illustration The following screens show the different views of the configuration editor.  

How to access 
the editor

The following table shows the different ways of accessing the application browser.

Configuration

TSX 57452  V3.3 ... ;0:,
�;7,��

0 2 3 4

1

0

P
S
Y

2
6
0
0

T
S
X

5
7
4
5
2

Configuration

TSX 57402  V3.3 ;0:,
�;7,��

Number

Booleans:

Type Registers Words
16%R0

%R1 16
128
0

TMTimers
Series 7 
Monostables
Counters
Registers

T
MN
C
R
DRDrums

 Size of global address fields
512 Num

 Number of predefined Function Blocks

Configuration

TSX 57402  V3.3 ;0:,
�;7,��

No. of macro steps:

Grafcet module Execution parameters
Chart
Macro 0

8 / 64

Configuration parameters Execution parameters

Total no. of steps:   656 / 1024
(Including XMi IN and OUT steps)

128I
64

Macro 1 64
Macro 2 64
Macro 3 64
Macro 4 64
Macro 5 64
Macro 6 64
Macro 7 64

From: Action

the menu bar Select the Tools → Configuration command.

the application 
browser

Double click on the required configuration type, or select using the ar-
row keys and confirm with Enter.
24   09/2000



Introduction to PL7 editors
How to change 
from one 
configuration 
type to another

Click on the following icons to change from one configuration type to another. :

Hardware 
Configuration

The configuration editor is a user-friendly graphic interface, for defining and config-
uring the different parts of the PLC:
l rack,
l supply,
l processor,
l task modules,

Software 
configuration

The configuration editor maintains application software parametering by reporting:
l the number of function blocks,
l the number of registers,
l the size of global address fields.

Grafcet objects 
configuration

The configuration editor is used to define Grafcet objects (steps, macro-steps, etc.), 
and set operating parameters (number of active steps and transitions).

Icon Action

  displays the hardware configuration,

  displays the software configuration,

  displays the Grafcet configuration,

%MWI
%TI..
  09/2000 25



Introduction to PL7 editors
Program editors: General

At a Glance The program editors are used to program functions and tasks implemented by the 
application.
Four program editors are offered:
l ladder language editor (LD),
l instruction list language editor (IL),
l structured text language editor (ST),
l Grafcet language editor (G7) 

Illustration The following illustration shows a view of all the different program editors.  

LD: MAST - Sequential - Post

T.F3T.F4 T.F5T.F6 T.F8T.F2F12F11F10  F9 F6 F4 F3 F2 P S R OPERCOHPCOHPH V F (...) F5N  F7
X

  F8 T.F7

(* Mixing timer*)

%TM0%TM17

P IN TM

MODE:  TON

OUT

ST: MAST - Sequential - Prl
! (*  Updating cycle LED   *)

IF  %M0  THEN
SET  %M18;
ELSE  RESET  %M1
END_IF;

(*  Reset application

IF RE  %M21  THEN
SET  %S0;
END_IF;

IL:  MAST - List

! (*  Init  *)
LD % MW5: X4
ST %M3

 GRAFCET:  MAST - Sequential - Macro1

F11F8 F9F7F6F5F4F3F2 F10 F12 1F2  I N1F3OUT1F4

IN

(*Mixing time elapsed*)

(*Product evacuation + Mixing*)

(*Start mixer motor*)

0

26   09/2000



Introduction to PL7 editors
How to access an 
editor

The following table shows the procedure for accessing a program editor.

If the application From the application browser:

does not have a program Create or import a program module (section, subroutine, event, 
DFB) in one of the proposed languages.
To do this, refer to the Operate Modes on-line help.

has one or more 
program module(s)

Open the Program directory, select the required program module 
then double-click on it, or select it using the arrow keys and con-
firm with Enter.
  09/2000 27



Introduction to PL7 editors
Program editor: Ladder Language (LD)

At a Glance The Ladder Language editor is a graphics editor which is used to construct ladders 
(transcription of relay diagrams).
This editor is structured in zones, with tools and functions which can be directly ac-
cessed using the mouse or the keyboard. They include:
l basic tools (rungs, Boolean wires, spools, operation blocks, etc.),
l immediate call-up of tools for the assisted entry of library functions:
l direct access to a subroutine from a call program,
l different display modes.

Illustration The following screen shows the different zones which make up the Ladder Lan-
guage editor. 

Elements and 
functions

The following table shows in brief the different elements that make up the editor.

LD: MAST

T.F3 T.F4 T.F5 T.F6 T.F8T.F2F12F11F10  F9 F6 F4 F3 F2
P S R OPER COHP COHP

H V F (...)
 F5

N
 F7

X

  F8 T.F7

5

4

3

2
1 (* Mixing timer*)%L1

%I1.0 %TM2

%C0.E %M16
TMIN Q

Mode TON
TB:  1 mn
TM.P:  580
Modif:  Y

%TM2.Q %Q3.5 %Q3.5

Number Element Function

1 Label zone is used to enter a label

2 Comment zone is used to enter a comment

3 Test zone is used to locate elements such as rungs, function blocks, etc.

4 Action zone is used to locate elements such as spools and operation blocks.

5 Graphics palette is used to access different graphic language symbols 
directly.
28   09/2000



Introduction to PL7 editors
Entry modes The software suggests two entry modes:
l with comment (default entry mode),
l without comment.
This last mode allows graphic elements to be entered without supplying input infor-
mation, and batches this task when the ladder is completed.

Display modes Different display parameters allow the display mode to be adapted to the user’s re-
quirements.
These different parameters are: 
l normal view (default entry mode),
l collapsed view which displays a greater number of ladders while retaining the 

same level of information.
l display of operands as an address, a symbol, or both simultaneously,
l display of symbols limited to 10 characters (short text) or shown in full (long text: 

maximum of 32 characters).

How to change 
modes

The following table shows the procedure for changing modes.

Moving around 
the editor

The following table shows the procedure for moving around the editor using the key-
board.

Mode Command Key-
board 
shortcut

Entry Edit → Enter with Comment is used to switch from one mode 
to another.

-

Display View → Collapsed, Normal.
View → Addresses.
View → Symbols.
View → Symbols & Addresses.
View → Short Text, Long Text.

-
Ctrl + E
Ctrl + F
Ctrl + H
-

Movement Key (s)

From cell to cell Arrow

To the first column of the rung Home

To the last column End

To the next page PgDn

To the previous page PgUp

To the start of the ladder Ctrl + Home

To the end of the ladder Ctrl + End
  09/2000 29



Introduction to PL7 editors
Program editor: Instruction List (IL) Language

At a Glance The Instruction List language editor is used to write logic and digital processing in 
Boolean form. 
This editor uses functions such as:
l automatic imposition (alignment of instructions and operands),
l entry and display of operands in symbol and/or address form.
l Assisted entry:

l function block instructions (%TMi, %Ci, etc.),
l library functions,

l color display of the key language words and comments.

Illustration The following screen shows an example of a program constructed in Instruction List 
language. 

Moving around 
the editor

The following table shows the procedure for moving around the editor using the key-
board.

IL: MAST - Conveyor_mgt
* Verification of parts in drying position*)
             LD            %I1.0
             AND          %I1.1
             ST            %Q2.2  

(* Motor on*)
             LDN           %I1.0
             ANDN        %I1.4 
             AND          %I1.3
             ST             %Q2.0   

!

!

(* Parts count*)
             LD           %I1.5
             R             %C8

!

Statement start symbol

Comment zone
delimited by (*  *)

Instruction List (IL)

Delimitation of current statement

Movement Key (s)

From character to character Arrow keys

From word to word Ctrl + left and right arrow keys

To the beginning of the line Home

To the end of the line End

To the start of the program Ctrl + Home
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To the end of the program Ctrl + End

To the previous page PgUp

To the next page PgDn

Movement Key (s)
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Program editor: Structured Text language (ST)

At a Glance The Structured Text language editor is used to write logic and digital processing in 
a structured form (data processing type).
This editor uses functions such as:
l entry and display of operands in symbol and/or address form.
l assisted entry of library functions,
l color display of the key language words and comments.

Illustration The following screen shows an example of a program constructed in Structured Text 
language. 

Moving around 
the editor

The following table shows the procedure for moving around the editor using the key-
board.

ST: MAST - Sequentielle - Prl
(* Updating cycle LED*)
IIF  %M0  THEN
SET  %M18;
ELSE  RESET  %M18;
END_IF;

(*Reset application*)
IF  RE  %M21  THEN
SET  %S0;
END_IF;

!

Statement start symbol

Comment zone
delimited by (*  *)

Structured Text (ST) instructions

Delimitation of current statement

!

Movement Key (s)

From character to character Arrow keys

From word to word Ctrl + left and right arrow keys

To the start of the line Home

To the end of the line End

To the start of the program Ctrl + Home

To the end of the program Ctrl + End

To the previous page PgUp

To the next page PgDn
32   09/2000



Introduction to PL7 editors
Program editor: Grafcet language

At a Glance The Grafcet editor is used to represent the functioning of a sequential operation in 
a structured and graphic form.

This editor is made up of 8 pages of 14 lines and 11 columns that define those cells 
that are each able to receive a graphic element. 

It has numerous tools that allow user-friendly entry such as:
l a graphics palette directly accessible using the mouse or keyboard (steps, tran-

sitions, links, cross-references, macro-steps, etc.),
l direct access to programming of actions or transition conditions,
l automatic numbering of steps,
l a display using Grafcet pages with step and transition lines,
l a simplified entry of comments, 
l two display modes.

Illustration The following screen shows the different zones which make up the Grafcet Lan-
guage editor. 

 GRAFCET:  MAST  -  Sequential - Chart

F11F8 F9F7F6F5F4F3F2 F10 F12 1F2
 I N
1F3

OUT
1F44

2

1

3

(*First step*)
0

M0

1

2

3

M1

(*Cycle start conditions*)

(*Hopper filling*)

(*Mixer filling*)

(*End dosage*)

(*Mixing and evacuation*)

(*First step*)

(*Main chart*)
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Elements and 
functions

The following table shows in brief the different elements that make up the editor.

Display modes The software offers two display modes:
l normal view (default entry mode),
l collapsed view.
The latter allows a greater number of Grafcet pages to be displayed while retaining 
the same level of information.

How to change 
modes

The following table shows the procedure for changing modes.

Moving around 
the editor

The following table shows the procedure for moving around the editor using the key-
board.

Number Element Function

1 Grafcet Page allows the graph to be created

2 Step line allows steps, macro-steps, comments etc. to be entered.

3 Transition line allows transitions, comments etc. to be entered.

4 Graphics palette allows different graphic language symbols to be accessed.

Mode Command

Display View → Collapsed or View → Normal.

Movement Key (s)

From cell to cell Arrow keys

To the next page PgDn

To the previous page PgUp

To the start of the first page Ctrl + Home

To the end of the eighth page Ctrl + End
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DFB type editors

At a Glance The DFB editor is used for programming user–specific function blocks which work 
in accordance with the user’s application requirements.
These user function blocks are designed for structuring an application. They are 
used when a programming sequence is repeated within an application, or to freeze 
a standard programming set. 

Illustration The following screen shows the generic view of the DFB type editor.  

How to access 
the editor

The following table shows the procedure for accessing the DFB type editor.

1RWH��Creating DFBs requires PL7 Pro. It is possible to use DFBs with PL7 Junior 
and PL7 Pro.

Information zone

Access to
parameter zones

Access to the
program

editor

Code ...(ST)

DFB type editor: Count_1*
 Call interface  Status
Inputs + I/O : Outputs + I/O Not instantiated, offline mode

Interface and public variables Private variables Descriptive form

I/O
Type Init. valueCommentName

Inputs Outputs Public variables

InitBOOLInput1 FALSE

1 0

Parameter
zone

If the application Action

does not yet have a DFB 
type

Create a DFB type.
In order to do this, from within the application browser, right-click 
on the DFB Types directory then left-click on Create.

has DFB types Double-click on the required DFB type, or select using the arrow 
keys and confirm with Enter.
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The variables editor

At a Glance The variables editor is used to:
l create symbols for the different application items (bits, words, function blocks, 

task modules, etc.)
l create parameters for predefined function blocks (timers, counters, etc.)
l enter constants values and select the display base (decimal, binary, hexadeci-

mal, floating, message),
l instantiate and create parameters for DFB user function blocks.

Illustration The variables editor appears thus:  

How to access 
the editor

 The following table shows the procedure for accessing the variables editor.

Main functions of 
the editor

Access to the variables is made easier by:
l classification by family and type,
l sort functions (sort by symbols or address),
l the option of displaying all the objects associated with one variable (for example 

all the bits of a word, all the objects associated with a predefined function block),
l the option to pre-symbolize objects for certain tasks,
l the option to start a wild-card search on a symbol or comment,

Variables

Parameters I/O 1: TSX DEY 16D2 Entry field

%CH1.MOD

Address Type Symbol Comment

P

%CH1.MOD
%I1.MOD.ERR
%MW1.MOD
%MW1.MOD.1
%MW1.MOD.2
%CH1.0
%KW1.0
%KW1.0.1
%KW1.0.2
%I1.0
%I1.1
%I1.2
%I1.3
%I1.4
%I1.5
%I1.6
%I1.7
%I1.0.ERR

CH
EBOOL
WORD
WORD
WORD

CH

WORD
WORD
EBOOL
EBOOL
EBOOL
EBOOL
EBOOL
EBOOL
EBOOL
EBOOL
BOOL

WORD

Part_present
v1_Sensor in

Init
Stop

v1_Sensor out
v1_Sensor in
v2_Sensor out

detects a part in front of cylinder v 1
sensor for cylinder v 1 in position
sensor for cylinder v 1 out position
sensor for cylinder v 2 in position
sensor for cylinder v 2 out position
starts system
stops automatic cycle

Step Action

1 From the application browser, open the Variables directory. 

2 Double-click on the variables type required, or select using the arrow keys and 
confirm with Enter.
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l the option to filter the I/O (only displays the input or output variables affecting the 
process for one module),

l The option to Copy / Paste SFB parameters,
l the option to Cut / Copy / Paste the symbols and comments from a string of vari-

ables,
l the option to delete Pre-symbolization,
l bold display of variables used in the program,
l display of overlapping variables used in the program in red,
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Animation tables editor

At a Glance The animation tables editor is used to create tables containing lists of variables to 
be monitored or modified. 
This editor offers functions such as:
l manual creation of tables by entering variables ,

or
automatic creation from entire or partial program sections or animated objects in 
a runtime screen,

l modification of the current value of variables,
l forcing the current value of bit objects,
l choice of the display base for the current value (decimal, binary, hexadecimal, 

etc.),

Illustration The animation tables editor appears thus: 

Modify

0

1

Force to 0

Force to 1

Unforce

F3

F7

F8

F4

F5

F8

 0
Current value Kind

 0
 0
 5
 0
 0
 0
 0
 0
 0
 0
 0
 0
 0
 0

 %M17
 %TM0.V
 %TM0.P
 %TM0.Q
 %M15
 %M200
 %M16
 %MD12
 %X0.0
 %M10
 %MD8
 %X0.1
 %M12
 %X0.3

Trig_timer_mix_a
Mixer_Mixing_timer
Mixer_Mixing_timer
Mixer_Mixing_timer
End_Mixing_a
Step_empty_mixer
Timer_sec_empty_a
Trig_mix_a
Liters_mixer
Step_fill_hop1_P
Trig_prod_a
Step_fill_hop1_P
Trig_prod_b
Step_fill_hop2_p

2/3
Type

 Forcing

Modification

Dec.
 Display

Symbol/NameAddress Comment
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How to access 
the editor

The following table shows the different ways of accessing the animation tables edi-
tor.

If the application From the application browser 
(manual creation)

From an editor (automatic cre-
ation)

does not have an ani-
mation table

Create an animation table.
In order to do this, from within the 
application browser, right-click 
on the Animation Tables direc-
tory then left-click on Create.

Access the program module in 
which the table has been creat-
ed, then select the required rung, 
sequence, instruction or DFB.
Select Initialize Animation Ta-
ble (contextual menu).
Tables created automatically can 
be modified later on by deleting 
or adding new variables.

has one or more ani-
mation tables

Open the Animation tables di-
rectory and select the required 
table, then double click on it, or 
select using the arrow keys and 
confirm with Enter.
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Documentation editor

Introduction The documentation editor is used to configure, view and print the application folder.
It is linked with the documentation browser which shows the folder setup in a tree 
structure. 
This editor is used to set :
l a title page, containing the designer and project names,
l pages of general information,
l a cartridge.
It automatically generates :
l the contents,
l the application folder : hardware/software and program configurations,
l a list of variables, sorted by address or by symbol,
l cross references, sorted by address or symbol.

Illustration The following illustration shows a view of  the entire documentation editor. 

How to access 
the editor

The following table shows the procedure for accessing the folder editor.

MAST Task (20)
Application Structure  (1)

Rack configuration (2)

File MACHINE_PROPORTIONING (68)

DFB Types (8)

Sections (20)
Sequential (17)
Filling in (2)
Emp_mixerr (1)

Hardware configuration (9)

Function View

Module parameters (7)

Program (24)

Contents (1)
Title page (1)

Configuration (10)

Software configuration (1)

FAST Task (3)

MAST - FILLING IN

Cross references (5)
Animation tables (3)
Variables (16)
Cartridge

Documentation : Filling in - Page 1/2 *

From : Action

the application 
browser

Double click on the Folder directory or select it using the arrow keys 
and confirm with Enter. 
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Runtime screens editor

At a Glance The runtime screens editor is a tool designed to facilitate operation of an automatic 
process.
Using this tool, a designer can develop process-adapted screens which offer the op-
erator:
l a non-encrypted display of information: explanatory text, dynamic values, color 

diagrams, etc.
l the possibility to work simply and quickly:  dynamic modification and surveillance 

of PLC variables, etc.
The runtime screens editor has three windows whose sizes can be parameterized:
l the browser used to access the different runtime screens,
l the graphics editor which allows the creation, modification and operation of 

screen animation,
l the display window, used for help in debugging an application, and providing sim-

ple display of diagnostic messages.

1RWH��Creating or using runtime screens requires PL7 Pro.
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Illustration The following screen shows the different zones which make up the runtime screens 
editor. 

How to access 
the editor

The following table shows the procedure for accessing the runtime screens editor.

Browser

Graphics editor

Display window

ONLINE U:SYS MOD OVR[x:244,y:323]

RUN ??? ???
RUN

File Edit ?
PL7 PRO: test – [Runtime Screen: Dosage – Mixture – Products]

Utilities View Tools PLC Debug Options Window

Screen

STOP

RUN

Message StatusDisappears.AppearsZoneErrorAcknowledgment
Not EV_DIA 4 01/01/70. 0... Cond1<> TRUE or Cond0<>FA... 0
Acknowledged
No MV_DIA 5 01/01/70. 0... Debug status Words 0
acknowledgment

&

1

0

1

0

$ %

4 3 7

PROCESS_STATUS

Logon_screen

Control_screen

Read_me

Hopper_1 Hopper_2

Mixer

24

Mixer_Tempo

Silo_A Silo_B Silo_C

1 – Logon_screen
2 - Control_screen
3 - Read_me
4 – Debug_screen
5 – Debug_information
6 - Logon
7 - Presentation
Animation Example

9 - Colors
14 - Various trend di
15 - Animation test

Series 1000 family
1022 – Multi Animation
1001 – Dif. manage
1002 - Clock
1020 – Viewer Test

0 – Dosage_Mixture_Pro

If the application Action to be taken from the application browser:

does not have a runtime 
screen

Right-click on the Runtime Screens directory then left-click 
on Open

has one or more runtime 
screens

Open the Runtime screens directory and select the required 
table, then double-click on it, or select using the arrow keys 
and confirm with Enter.
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Creating an application
At a Glance

Overview This chapter introduces the principles of creating an application. 

What’s in this 
Chapter?

This Chapter contains the following Maps:

1RWH��For further information (functions, access, etc.), refer to either of the follow-
ing:
l PL7 on-line Help,
l the various manuals available on CD-ROM.
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Creating an application
Creation principles

Introduction 2 development stages are involved in creating an application, each one containing 
several steps:
l a stage in offline mode,
l a stage in online mode.

The different 
development 
stages

The flowchart below shows the different stages of developing an application. 

Creating an
application

Editing the
configuration

Programming

Parametering of software, 
Grafcet and applications

Parametering or
utilization

Parametering or
utilization

Editing
runtime screens

Master task, fast task events, 
sections,

Functional modules

Parametering or
utilization

Structure of programs

Editing DFB types

Editing
variables

Symbolization of bits, 
words, etc. 

Local mode

Transfer

Animation tables

Debugging
the application

Saving 
the application

Building the 
documentation file for 

the application

Building the 
documentation file

Online mode

Runtime screens
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1RWH��Certain development steps require the use of PL7 Junior or PL7 Pro (see 
PL7 reference manual).
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Creating an application
Local mode

Introduction Local mode (ie. no connection to the PLC) is used for creating or modifying an ap-
plication at the terminal. This application is located in the work directory on the hard 
drive. 
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Online mode

At a Glance Online mode (ie. connected to the PLC) can be used to modify an application within 
the PLC.
The following functions can be performed:
l creation/modification of an LD, IL or ST program,
l modification of task period,
l modification of the parameters of predefined function blocks (except size of reg-

isters),
l modification of module data and parameters,
l import, application export, PLC in Stop mode,
l addition of predefined function blocks,
l  debugging, adjustment,
l creation/modification of runtime screens,
l modification of Grafcet or DFB structure in STOP mode.

Connection 
problems

This paragraph provides solutions for problems involving connection or disconnec-
tion from the PLC. Carry out operations in the recommended order. Only continue 
to the next operation if the problem is still unresolved.
For a portable terminal:
l Deactivate the energy manager,
For all types of PC:
l Replace the video and mouse drivers with Microsoft drivers.
l Set Rx Tx to 0 in the driver parameters.
l Deactivate the anti-virus software (if it is installed).
l Enter 2 as the number of connection attempts in PLC → Define PLC address... 

→ Options → Retry number.

1RWH��When a modification is made in online mode, the application is updated 
through auto-save to the PLC, and through manual save to the working directory 
on the hard drive.
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Creating an application

Introduction By creating an application, it is possible to select :
l the type of PLC,
l the processor type,
l the type of memory card.

How to create an 
application

 The table below describes the procedure for creating an application

Step Action

1 Select the File → New command.

2 Select the hardware base.

3 Select the processor type.
For processors before version V3.0, the Grafcet option must be selected for 
use within the application (for version > V3.0 processors, a Grafcet application 
is created by defining a Grafcet section in the master task). 

4 Select the appropriate type of memory card. The type of memory card can al-
ways be modified later on while configuring the processor.
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Program structure

At a Glance PL7 software allows two types of program structure:
l a mono-task structure consisting of the master task (MAST) structure as a de-

fault,
l a multitasking structure which consists of the master task, fast task (FAST) and 

EVT processing as defaults.
PL7 program tasks are made up of several parts (called sections), and subroutines. 
Each of these sections can be programmed in a language appropriate to the process 
to be performed.
This breakdown can be used to create a structured program and to generate or in-
sert program modules with ease.

Task 
management

Master task and fast task (where programmed) are active by default.
The event task is activated when the associated event occurs.
When a fast task event occurs or its cycle starts, the running of lower priority tasks 
is stopped in order to deal with the fast task operation. The interrupted task is rein-
stated when priority task operations are completed.

Example of a 
multitasking 
program 
structure

The figure below gives an example of an application with a multitasking structure. 

/'/'

/'/'

/'/'

Program
MAST task

Sas

Four_1
Drying
Paint

SR0

SR1

Alarm_sas

Sec_mon

SR

Sections

SR

Evt0
Evt1

FAST task

Events

Sections
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PL7 program transfer

Role An entire application can be exchanged with program transfer, apart from the oper-
ating screens.
Two transfer directions are possible :
l from the terminal (PC) to the PLC (AP),
l from the PLC to the terminal.

How to transfer 
an application

PC - > PLC program transfer

PLC  - > PC program transfer

Step Action

1 Select the AP → Transfer Program command.

2 Select the PC - > PLC transfer then confirm with OK.

3 If a cartridge for storage of symbols and comments is shown in the configura-
tion, the symbols box may be used : you can choose to complete or delay the 
symbols transfer to a subsequent transfer run.

Step Action

1 Select the AP → Transfer Program command.

2 Select : the PLC - > PC transfer then confirm with OK.
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PL7 data transfer

Role Data transfer allows variables, symbols and comments concerning the application 
to be exchanged.
Two transfer directions are possible:
l from the file located on the terminal (PC) to the PLC (AP),
l from the PLC to the file located on the terminal 

How to transfer 
data

Data transfer from PLC -> File

Data transfer from file -> PLC

Step Action

1 Select the PLC → Transfer Data command.

2 Select the PLC -> File transfer.

3 Define the transfer parameters:
l the range of %MW values to be transferred,
l the name of the file where the data is to be stored.

4 Confirm with OK.

Step Action

1 Select the PLC → Transfer Data command.

2 Select the File -> PLC transfer.

3 Define the name of the file to be transferred.

4 Confirm with OK.
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PL7 application debugging

At a Glance PL7 software provides a full set of tools for debugging applications.
A tools palette gives direct access to the main functions:
l a program debug bar which can, for example, be used for:

l placing of breakpoints,
l step by step operation of the program,
l application monitoring.

l a PLC debug screen which offers:
l information on the status of the application,
l access to program diagnostics and task modules,
l access to the display and updating of the realtime clock.

l the Grafcet debug browser which gives a hierarchical view of the chart.
l a Grafcet debug bar which can be used to display or modify chart status.

How to access 
the debugging 
tools

The table below shows the access commands for the different debugging tools.

Debugging tool Access

Program Select the Debug → Program Debug Bar command.

PLC Select the Debug → Access PLC Debug Screen command.

Grafcet Browser Select the Utilities → Debug Grafcet command.

Grafcet Bar Select the Debug → Grafcet Debug Bar command.

1RWH��You must be in online. (See 2QOLQH�PRGH��S����)
52   09/2000



Creating an application
PL7 Diagnostics

At a Glance PL7 software can carry out diagnostics in online mode at different application levels 
such as:
l the system (operating system, programming workshop, MMI) using the diagnos-

tics system (PL7 V4 function),
l the process, using DFB application diagnostics and DFB command and diagnos-

tics of the operative section,
l the PLC (last operation stop , module call stack),
l the modules (errors classified according to their category),
l the program (cause and source of error),

How to access 
the diagnostics 
functions

The PL7 diagnostics functions are allocated to different editors or tools in the PL7 
software.
To access the different diagnostics functions, refer to the PL7 on-line Help.

1RWH��Use of DFBs requires PL7 Junior or PL7 Pro.
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4
Additional tools
At a Glance

Overview This chapter shows the additional tools available in PL7.

What’s in this 
Chapter?

This Chapter contains the following Maps:

1RWH��For further information (functions, access, etc.), refer to either of the follow-
ing:
l PL7 on-line Help,
l the various manuals available on CD-ROM.
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Additional tools
Converters

Introduction The converters are designed to portage existing applications simply and effectively 
to the TSX Micro and TSX Premium PLCs.
Four converters are offered :
l PL7-2 to PL7,
l PL7-3 to PL7,
l ORPHEE to PL7,
l SMC to PL7.

How to access 
the converters

The following table shows the procedure for accessing the conversion function.

Step Action

1 Create an empty application to receive the converted application. 

2 Select the File → Convert command.

1RWH��The SMC converter is an optional converter to PL7 Junior or PL7 Pro (Ref-
erence TLX LC SMC PL7 30M).
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Import/Export

At a Glance The Import/Export functions for TSX Micro or TSX Premium PLC applications affect:
l the application, a section, a functional module, an animation table,
l all or part of the IL, LD, ST, Grafcet, DFB Type, Symbol source program modules,
The source file code is in 8 bit ASCII conforming to the standard ISO 8859-1. Code 
can be entered directly using WINDOWS-compatible editors such as Word in text 
format (*.TXT).

File extensions Files to be imported or exported are of the following types:
l application source marked with *.FEF,
l application source in FNES format, marked with *.FNE,
l functional module source, marked with *.FM,
l LD source, marked with: *.LD,
l IL source, marked with: *.IL,
l ST source marked with: *.ST,
l Grafcet source, marked with: *.GR7,
l symbols source, marked with: *.SCY or *.TXT (compatible with Excel),
l DFB type source, marked with: *.DFB,

How to access 
the 
Import/Export 
function

The following table shows the procedure for accessing the Import/Export function.

1RWH��Binary formats are not accessible (they are encrypted).

Step Action

1 Select the File → Import/Export command.

1RWH��use the 2SWLRQV → &XVWRPL]H command to identify the access path to 
source files.
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Cross references for an application variable

Introduction Cross references are mainly used when debugging an application in order to identify 
the cause of a failed variable.
They are designed to :
l locate all tasks, sections and programming lines where a variable or a DFB type 

(in address or symbol form) is used,
l go directly the relevant lines,
l display the search and browser archives.

Illustration The cross referencing tool appears thus: 

How to access 
the tool

The following table shows the procedure for accessing the cross referencing tool.

1RWH��Cross references apply to the application and not to the operating screens.

Cross References

Find
 Find

Extract bits

New

Tables
Channel objects
Network objects

SFB/DFB objects
OFB instance

%MW0

%MW0
Referenced objects Reference Use Occ.*

MAST - MAST_MAIN - TOP
MAST - MAST_MAIN - TOP+ 3

ST

ST

Refresh R W

Symbol:    Table_digit

W 1
7R[ ]

Address: %MW0

Step Action

1 Select the Cross references command from theTools menu.
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Replacing a variable in the application

At a Glance The Replace Variables function is used to find and replace an application variable 
in address or symbol form.
Replacement within the application can be whole or partial, automatic or manual.
It affects the indicated variable as well as related items (eg. word extract bits, etc.) 
with the exception of activity time for Grafcet step bits (%Xi.T).
Replacement is carried out on the following levels:
l application (in all tasks),
l tasks (Mast, Fast, Evt),
l partial or complete section,
l entire functional modules, (sub-modules included).

Illustration The Replace Variables tool appears thus: 

How to access 
the tool

The following table shows the procedure for accessing the Replace Variables tool.

1RWH��The 5HSODFH�9DULDEOHV function refers to the application and not to the runt-
ime screens

Replace

Next Replace All

Close

Replace with:

?

MAST Task
Program

Sections

Mixer 1
Mixer 2

FAST Task
Sections

DIAG_MOTOR
From: To:

TOP
%L1
BOTTOM

TOP
%L1
BOTTOM

0 0

Find:
%MW3

%MW8

Step Action

1 Select the Replace Variables command from the Tools menu.
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Application protection

Introduction The Protection function for the application is used in local mode for:
l global protection of the application,
l global or partial protection of sections.

Global 
application 
protection

This function ensures the read and write protection of an application when it has 
been transferred within the PLC. 
Only the Run , Stop and Init functions are authorized within a protected PLC appli-
cation.

Global or partial 
protection of 
sections.

For each section, it is possible to set the protection type :
l no protection,
l write protection,
l read and write protection.

How to access 
the application’s 
Protection 
function

Application protection

Protecting sections

:$51,1*

Global protection of an application is irreversible. A protected applica-
tion cannot be modified. The only option is to load a new application into 
the PLC.

)DLOXUH�WR�REVHUYH�WKLV�SUHFDXWLRQ�FDQ�UHVXOW�LQ�VHYHUH�LQMXU\�RU�
HTXLSPHQW�GDPDJH�

Step Action

1 Select the Edit → Properties command.

2 Select the Protection tab.

If protection is Step Then …

global 1 Select the Edit  → Properties  command.

2 Select the Protection  tab.
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partial 1 Select the Programs,Task … , Sections  directory from the 
application Browser.

2 Select the Protection of included sections  contextual menu 
(right mouse-click) 

individual 1 Select the section to be protected.

2 Select the Edit  → Properties  command.

If protection is Step Then …
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PL7 access security management

Introduction PL7 access security management both limits and monitors access to the different 
PL7 functions. 
It can be used to… :
l create/modify a user list,
l import a user list,
l export a user list,
l activate the "PL7 access security management" function,
l change its password.
It is to be applied at the terminal where PL7 software is installed, but not to the ap-
plication itself

User profiles Five user profiles are offered :
l Read Only,
l Operate,
l Adjust,
l Debug,
l Program.

How to access 
the PL7 access 
management 
tool

The super user alone may have the necessary privileges to manage user rights.

Step Action

1 Select the Access security management program using the Start → Programs 
→ Modicon Télémécanique  command.

2 Enter the access name for the super user : Supervisor . By default, access does 
not require a password.

3 Confirm with  Ok. 
62   09/2000



Additional tools
OS-LOADER

Introduction This tool updates the operating system (OS) of the TSX Micro and TSX Premium 
PLCs, by downloading via the terminal port.
It is used to :
l display the OS version of the PLC ,
l download the operating system into the PLC system memory.

How to access 
the OS-LOADER 
tool

The table below shows the procedure for accessing the OS-LOADER tool.

:$51,1*

The download operation involves a sensitive stage during which any 
break in the PLC power supply could make it unusable.

)DLOXUH�WR�REVHUYH�WKLV�SUHFDXWLRQ�FDQ�UHVXOW�LQ�VHYHUH�LQMXU\�RU�
HTXLSPHQW�GDPDJH�

Step Action

1 Select the OS-LOADER PL7…  program. using the Start  → Programs  → Modicon 
Téléméchanique  command
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